summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Hasse2022-10-19 20:47:37 -0500
committerChristopher Hasse2022-10-19 20:47:37 -0500
commit96707047db031a5997760a5ed6b7806ff840dbbe (patch)
tree95abba32472070a693f3f5d9fc44a259d3b7921e /PKGBUILD
parent05e0aaa162ad460af82c3e09823b704ce38b3f05 (diff)
downloadaur-96707047db031a5997760a5ed6b7806ff840dbbe.tar.gz
Switch to applying the PR directly
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93f70dea3412..d8d6ea982917 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: chrhasse <hasse dot christopher at gmail dot com>
pkgname='alacritty-sixel-git'
_pkgname="alacritty"
-pkgver=0.12.0.2066.g53110c6e
+pkgver=0.12.0.2074.ga9335fcb
pkgrel=1
epoch=1
arch=('x86_64' 'i686')
-url="https://github.com/microo8/alacritty-sixel"
+url="https://github.com/alacritty/alacritty"
pkgdesc="A cross-platform, GPU-accelerated terminal emulator"
license=('Apache')
depends=('freetype2' 'fontconfig' 'libxi' 'libxcursor' 'libxrandr')
@@ -13,9 +13,16 @@ makedepends=('rust' 'cargo' 'cmake' 'fontconfig' 'ncurses' 'desktop-file-utils'
checkdepends=('ttf-dejavu') # for monospace fontconfig test
provides=('alacritty')
conflicts=('alacritty')
-source=("$_pkgname::git+https://github.com/microo8/alacritty.git")
+source=("$_pkgname::git+https://github.com/alacritty/alacritty.git")
sha256sums=('SKIP')
+prepare() {
+ cd "$_pkgname/alacritty"
+ git config user.name "user"
+ git config user.email "user@domain.fake"
+ git pull -X theirs origin pull/4763/head --no-edit
+}
+
pkgver() {
cd $_pkgname/alacritty
echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2|cut -d\- -f1).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"