summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEvgeniy Alekseev2023-08-17 14:47:07 +0300
committerEvgeniy Alekseev2023-08-17 14:47:07 +0300
commitc427247b70df24e824fcfb8b643b84f5e3114cf4 (patch)
treee1b6f06b4b7e03392ffee741813c05f2e69ec4a0 /PKGBUILD
parent8db335f88b9244fefdcffac354888e9f75664ffe (diff)
downloadaur-c427247b70df24e824fcfb8b643b84f5e3114cf4.tar.gz
albert 0.22.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 21 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d125e600da9b..08ae28673def 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,29 @@
+# Maintainer: Evgenii Alekseev
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: Manuel Schneider <manuelschneid3r at googles mail>
pkgname=albert
-pkgver=0.22.2
+pkgver=0.22.3
pkgrel=1
pkgdesc="A sophisticated standalone keyboard launcher"
arch=('x86_64')
url="https://github.com/albertlauncher"
license=('GPL')
depends=('hicolor-icon-theme' 'qt6-scxml' 'qt6-svg')
-makedepends=('cmake' 'git' 'libqalculate' 'muparser' 'pybind11' 'python')
-optdepends=('libqalculate: calculator plugin'
+makedepends=('cmake' 'git' 'libqalculate' 'muparser' 'pybind11' 'python' 'qt6-declarative')
+optdepends=('ddgr: duckduckgo search plugin'
+ 'libarchive: documentation plugin'
+ 'libqalculate: calculator plugin'
'muparser: another calculator plugin'
'python: python extension'
- 'python-urllib3: python web plugins')
+ 'python-docker: docker plugin'
+ 'python-googletrans: google translate plugin'
+ 'python-pylatexenc: TeX plugin'
+ 'python-urllib3: python web plugins'
+ 'python-virtualbox: virtualbox plugin'
+ 'qt6-declarative: qml widget box plugin'
+ 'qt6-5compat: qml widget box plugin'
+ 'qt6-shadertools: qml widget box plugin')
source=("mirrors/albert::git+https://github.com/albertlauncher/albert.git#tag=v${pkgver}"
"mirrors/plugins::git+https://github.com/albertlauncher/plugins.git"
"mirrors/python::git+https://github.com/albertlauncher/python.git"
@@ -52,21 +62,25 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_FIND_PACKAGE_RESOLVE_SYMLINKS=ON \
-DQHOTKEY_INSTALL=OFF \
- -DBUILD_WIDGETSBOXMODEL=ON \
-DBUILD_APPLICATIONS_XDG=ON \
- -DBUILD_CALCULATOR=ON \
+ -DBUILD_CALCULATOR_MUPARSER=ON \
+ -DBUILD_CALCULATOR_QALCULATE=ON \
-DBUILD_CHROMIUM=ON \
+ -DBUILD_CLIPBOARD=ON \
+ -DBUILD_DATETIME=ON \
-DBUILD_DEBUG=OFF \
-DBUILD_FILES=ON \
-DBUILD_HASH=ON \
-DBUILD_PYTHON=ON \
+ -DBUILD_QMLBOXMODEL=ON \
-DBUILD_SNIPPETS=ON \
-DBUILD_SSH=ON \
-DBUILD_SYSTEM=ON \
-DBUILD_TEMPLATE=OFF \
-DBUILD_TERMINAL=ON \
-DBUILD_URLHANDLER=ON \
- -DBUILD_WEBSEARCH=ON
+ -DBUILD_WEBSEARCH=ON \
+ -DBUILD_WIDGETSBOXMODEL=ON
make
}
@@ -83,4 +97,3 @@ package() {
}
# vim:set ts=2 sw=2 et:
-