summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEvgeniy Alekseev2022-03-31 16:46:54 +0300
committerEvgeniy Alekseev2022-03-31 16:46:54 +0300
commitc61733c4b0044d74807310c732cf9fec3bc77f6b (patch)
tree2c8232c39790ccd0a9f28215c1024ef7ad6bad65 /PKGBUILD
parent69bc39f02881028791cc775eab10d3af329f3f73 (diff)
downloadaur-c61733c4b0044d74807310c732cf9fec3bc77f6b.tar.gz
albert 0.17.2-2
explicitly load and checkout submodules inside submoduls
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 85cb273ee094..b0b32c46e000 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=albert
pkgver=0.17.2
-pkgrel=1
+pkgrel=2
pkgdesc="A sophisticated standalone keyboard launcher"
arch=('x86_64')
url="https://github.com/albertlauncher"
@@ -16,10 +16,14 @@ optdepends=('muparser: Calculator plugin'
source=("mirrors/albert::git+https://github.com/albertlauncher/albert.git#tag=v${pkgver}"
"mirrors/plugins::git+https://github.com/albertlauncher/plugins.git"
"mirrors/python::git+https://github.com/albertlauncher/python.git"
- "mirrors/pybind11::git+https://github.com/pybind/pybind11.git")
+ "mirrors/pybind11::git+https://github.com/pybind/pybind11.git"
+ "mirrors/xkcd-plugin::git+https://github.com/bergercookie/xkcd-albert-plugin.git"
+ "mirrors/jetbrains-plugin::git+https://github.com/mqus/jetbrains-albert-plugin.git")
sha512sums=('SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
@@ -36,6 +40,14 @@ prepare() {
git config submodule.python/pybind11.url "$srcdir/pybind11"
git config submodule.python/share/modules.url "$srcdir/python"
git submodule update python/pybind11 python/share/modules
+
+ cd "$srcdir/albert/plugins/python/share/modules"
+ git submodule init
+ git config submodule.jetbrains_projects.url "$srcdir/jetbrains-plugin"
+ git config submodule.xkcd.url "$srcdir/xkcd-plugin"
+ # currently submodules are out-of-dated in upstream
+ # so we have to checkout them
+ git submodule update --remote --merge jetbrains_projects xkcd
}