summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOliver Anhuth2017-10-09 09:57:51 +0200
committerOliver Anhuth2017-10-09 09:57:51 +0200
commit1ba855bc7fe93abf41e75eda71d47a15021ff322 (patch)
tree678520e09630daa4ff87abb394adc0372bb0f78c /PKGBUILD
downloadaur-1ba855bc7fe93abf41e75eda71d47a15021ff322.tar.gz
Initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD89
1 files changed, 89 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2bc9a8998158
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,89 @@
+# Maintainer: Manuel Schneider <manuelschneid3r at googles mail>
+pkgname=albert-lite
+pkgver=0.13.1
+pkgrel=1
+pkgdesc="A sophisticated standalone keyboard launcher. Without QML and VirtualBox dependencies"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/albertlauncher"
+license=('GPL')
+depends=(
+ 'qt5-svg'
+ 'qt5-x11extras'
+ 'libx11'
+)
+makedepends=(
+ 'git'
+ 'cmake'
+ 'gcc'
+ 'qt5-svg'
+ 'muparser'
+)
+optdepends=(
+ 'muparser: Calculator plugin'
+)
+provides=('albert')
+conflicts=('albert-git'
+ 'albert')
+source=('git+https://github.com/albertlauncher/albert.git'
+ 'git+https://github.com/albertlauncher/plugins.git')
+md5sums=('SKIP' 'SKIP')
+
+
+prepare() {
+ cd "${srcdir}/albert"
+ git checkout "v${pkgver}" > /dev/null 2>&1
+ git submodule init
+ git config submodule.plugins.url $srcdir/plugins
+ git submodule update plugins
+}
+
+
+build() {
+ echo -e "
+
+ ╭──────────────────────────────────────────────╮
+ │ │
+ │ \e[31mThis is a plugin based application\e[0m │
+ │ \e[31mCheck the optional dependencies\e[0m │
+ │ │
+ │ If you plan to report bugs please modify │
+ │ the PKGBUILD to build the debug version. │
+ │ │
+ ╰──────────────────────────────────────────────╯
+"
+
+ [[ -d "build" ]] || mkdir -p "build"
+ cd "build"
+
+ cmake \
+ "../albert" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE="Release" \
+ -DBUILD_WIDGETBOXMODEL=ON \
+ -DBUILD_QMLBOXMODEL=OFF \
+ -DBUILD_APPLICATIONS=ON \
+ -DBUILD_CALCULATOR=ON \
+ -DBUILD_CHROMEBOOKMARKS=ON \
+ -DBUILD_EXTERNALEXTENSIONS=ON \
+ -DBUILD_DEBUG=OFF \
+ -DBUILD_FILES=ON \
+ -DBUILD_FIREFOXBOOKMARKS=ON \
+ -DBUILD_HASHGENERATOR=ON \
+ -DBUILD_KVSTORE=ON \
+ -DBUILD_MPRIS=ON \
+ -DBUILD_SSH=ON \
+ -DBUILD_SYSTEM=ON \
+ -DBUILD_TEMPLATE=OFF \
+ -DBUILD_TERMINAL=ON \
+ -DBUILD_VIRTUALBOX=OFF \
+ -Wno-dev
+ make
+}
+
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="$pkgdir/" install | grep -v '^-- '
+}
+
+# vim:set ts=2 sw=2 et: