summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXenhat Hex2021-12-26 15:17:56 -0500
committerXenhat Hex2021-12-26 15:17:56 -0500
commit8950ba5ea468754d4054297fcd816b9a48735138 (patch)
tree2affaa2df01e106af96a78da1d83ae892f249ba4 /PKGBUILD
parent3cce14f0b605e4edfa44f348ad7575c785a2e252 (diff)
downloadaur-8950ba5ea468754d4054297fcd816b9a48735138.tar.gz
respect makepkg.conf for LTO
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6dcb4abac224..b7c0c99cea29 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=alchemy-next-viewer-git
-pkgver=6.5.1.47913.d316ca1665
+pkgver=6.5.1.47926.7ae250d510
pkgrel=1
_branch="${AL_GIT_BRANCH:=main}"
pkgdesc="Next generation of the Alchemy Viewer, an open-source Second Life client - git version"
@@ -62,7 +62,7 @@ build() {
fi
fi
pip3 install --upgrade autobuild -i https://git.alchemyviewer.org/api/v4/projects/54/packages/pypi/simple --extra-index-url https://pypi.org/simple
- autobuild configure -A 64 -c ReleaseOS -- -DLL_TESTS:BOOL=OFF -DDISABLE_FATAL_WARNINGS=ON -DUSE_LTO:BOOL=ON -DVIEWER_CHANNEL="Alchemy Test"
+ autobuild configure -A 64 -c ReleaseOS -- -DLL_TESTS:BOOL=OFF -DDISABLE_FATAL_WARNINGS=ON -DUSE_LTO:BOOL=$(grep -cq '[^!]lto' <<< $OPTIONS && echo 'ON' || echo 'OFF') -DVIEWER_CHANNEL="Alchemy Test"
cd "build-linux-64" || exit 1
if ninja -j"$(nproc)"; then