summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXenHat2023-04-03 13:26:23 -0400
committerXenHat2023-04-03 13:26:23 -0400
commit550e01c0d67e428ebeeae4fb4ffaa8b125f8d498 (patch)
tree4b260ae40ecc7d7886b6c768c46c11394569430f /PKGBUILD
parentcfc68514597516122abd1413a21b6b235fcc8697 (diff)
downloadaur-550e01c0d67e428ebeeae4fb4ffaa8b125f8d498.tar.gz
shfmt, no functional changes
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD59
1 files changed, 30 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9dd5e9c910c2..684c056eef5f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,49 +14,50 @@ license=('LGPL')
depends=(dbus-glib glu gtk3 libgl libiconv libidn libjpeg-turbo libpng libxss libxml2 mesa nss openal sdl2 vlc zlib)
makedepends=('cmake' 'gcc' 'lld' 'python-virtualenv' 'python-pip' 'git' 'boost' 'xz' 'ninja')
optdepends=(
- 'alsa-lib: ALSA support'
- 'freealut: OpenAL support'
- 'gamemode: Gamemode support'
- 'lib32-libidn11: SLVoice support'
- 'lib32-libsndfile: SLVoice support'
- 'lib32-util-linux: SLVoice support'
- 'lib32-gstreamer0.10: SLVoice support'
- 'libpulse: PulseAudio support'
- 'mesa-libgl: Intel, Radeon, Nouveau support'
- 'nvidia-libgl: NVIDIA support'
- 'nvidia-utils: NVIDIA support'
- 'wine: More up-to-date, less buggy SLVoice support')
+ 'alsa-lib: ALSA support'
+ 'freealut: OpenAL support'
+ 'gamemode: Gamemode support'
+ 'lib32-libidn11: SLVoice support'
+ 'lib32-libsndfile: SLVoice support'
+ 'lib32-util-linux: SLVoice support'
+ 'lib32-gstreamer0.10: SLVoice support'
+ 'libpulse: PulseAudio support'
+ 'mesa-libgl: Intel, Radeon, Nouveau support'
+ 'nvidia-libgl: NVIDIA support'
+ 'nvidia-utils: NVIDIA support'
+ 'wine: More up-to-date, less buggy SLVoice support')
replaces=('alchemy-viewer-git')
install=alchemy.install
source=("${pkgname}"::'git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch='"${AL_BRANCH_OVERRIDE:-main}"
-'compile.bash')
+ 'compile.bash')
sha256sums=('SKIP'
'152dba0c45a146e3dfb6801af9885820414f271dbf48b1ae6f8603143a2e83f7')
pkgver() {
- cd "${pkgname}" || exit 1
- ( set -o pipefail
- printf "%s.%s.%s" "$(cat indra/newview/VIEWER_VERSION.txt)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ cd "${pkgname}" || exit 1
+ (
+ set -o pipefail
+ printf "%s.%s.%s" "$(cat indra/newview/VIEWER_VERSION.txt)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
prepare() {
- cd "${pkgname}" || exit 1
- export USE_VENV=1
- ../compile.bash prepare
+ cd "${pkgname}" || exit 1
+ export USE_VENV=1
+ ../compile.bash prepare
}
build() {
- cd "${pkgname}" || exit 1
- export USE_VENV=1
- ../compile.bash build
+ cd "${pkgname}" || exit 1
+ export USE_VENV=1
+ ../compile.bash build
}
package() {
- mkdir -p "${pkgdir}/opt"
- mkdir -p "${pkgdir}/usr/local/share/applications"
- # Patch shortcut to avoid duplicated entries
- sed -i 's;Name=Alchemy;Name=Alchemy (git build);' "${pkgname}/build-linux-64/newview/packaged/etc/refresh_desktop_app_entry.sh"
- sed -i 's;alchemy-viewer\.desktop;'"${pkgname}\.desktop"';' "${pkgname}/build-linux-64/newview/packaged/etc/refresh_desktop_app_entry.sh"
- mv "${pkgname}/build-linux-64/newview/packaged" "${pkgdir}/opt/${pkgname}"
+ mkdir -p "${pkgdir}/opt"
+ mkdir -p "${pkgdir}/usr/local/share/applications"
+ # Patch shortcut to avoid duplicated entries
+ sed -i 's;Name=Alchemy;Name=Alchemy (git build);' "${pkgname}/build-linux-64/newview/packaged/etc/refresh_desktop_app_entry.sh"
+ sed -i 's;alchemy-viewer\.desktop;'"${pkgname}\.desktop"';' "${pkgname}/build-linux-64/newview/packaged/etc/refresh_desktop_app_entry.sh"
+ mv "${pkgname}/build-linux-64/newview/packaged" "${pkgdir}/opt/${pkgname}"
}