summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorByeonghoon Yoo2018-08-03 15:18:53 +0900
committerByeonghoon Yoo2018-08-03 15:18:53 +0900
commit65fac434e1ac4bbacb56634dc5fc6c7bf8ceeafc (patch)
tree8a5b6dd83c59737eddd7f83a101271d26d7dd967 /PKGBUILD
downloadaur-65fac434e1ac4bbacb56634dc5fc6c7bf8ceeafc.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9480205a800e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Byeonghoon Yoo <bh322yoo@gmail.com>
+
+_name='alias-tips'
+
+pkgname="${_name}-git"
+pkgver=r97.77c7aa2
+pkgrel=1
+pkgdesc='An oh-my-zsh plugin to help remembering those aliases you defined once'
+arch=('any')
+license=('unknown')
+url='https://github.com/djui/alias-tips'
+depends=('zsh')
+makedepends=('git')
+source=("${_name}::${url//https/git}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${_name}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_name}"
+ install -d "${pkgdir}/usr/share/zsh/plugins/${_name}"
+ cp -a --no-preserve=ownership *.py *.zsh "${pkgdir}/usr/share/zsh/plugins/${_name}"
+}