summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2021-05-30 09:39:12 +0200
committerbartus2021-05-30 09:39:12 +0200
commit55331a0c9e47c5f821059e725c225e32f7a01cec (patch)
treeadef02942c8f37a08b97a072713807768370438d /PKGBUILD
parent1654306e526190a342f3832ce6458a31d4b0c6e9 (diff)
downloadaur-55331a0c9e47c5f821059e725c225e32f7a01cec.tar.gz
gcc:11 porting
https://gcc.gnu.org/gcc-11/porting_to.html#header-dep-changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dfbc6700e660..bd80a9343b94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,7 +40,7 @@ _name=alice-vision
_fragment="#branch=develop"
pkgname=${_name}-git
-pkgver=2.4.0.r62.g2f2768071
+pkgver=2.4.0.r74.gd5662a267
pkgrel=1
pkgdesc="Photogrammetric Computer Vision Framework which provides a 3D Reconstruction and Camera Tracking algorithms"
arch=('i686' 'x86_64')
@@ -77,6 +77,8 @@ prepare() {
# fix doc build
sed -i '/^ *install.*doc/s/doc/htmlDoc/' src/CMakeLists.txt
git apply -v "${srcdir}"/{cmake_cxx_std_14,openexr3}.patch
+ #fix gcc:11 headers regression
+ grep -lR "std::numeric_limits" src/aliceVision/hdr |xargs sed -i '1 i\#include <limits>'
}