summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2020-08-02 15:50:59 +0200
committerbartus2020-08-02 15:50:59 +0200
commitf6053582f687a5a5024ec2b4e2d54ad96e0d6ed4 (patch)
treeb411b5410286e821099c444172a83a7747a3ac76 /PKGBUILD
parent3a5834afbce2284b750e99d4afd50a3180d70f32 (diff)
downloadaur-f6053582f687a5a5024ec2b4e2d54ad96e0d6ed4.tar.gz
Fix build against cuda:11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8dff790ed58f..7cf31da66455 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _name=alice-vision
#_fragment="#commit=eebc3e4f"
_fragment="#branch=develop"
pkgname=${_name}-git
-pkgver=2.2.0.r493.g7c3126466
+pkgver=2.2.0.r946.g5c0412194
pkgrel=1
pkgdesc="Photogrammetric Computer Vision Framework which provides a 3D Reconstruction and Camera Tracking algorithms"
arch=('i686' 'x86_64')
@@ -25,11 +25,13 @@ source=("${pkgname}::git+https://github.com/alicevision/AliceVision.git${_fragme
"ute_lib::git+https://github.com/alicevision/uncertaintyTE.git"
"geogram::git+https://github.com/alicevision/geogram.git"
"submodule.patch"
+ "cuda11.patch"
)
sha256sums=('SKIP'
'SKIP'
'SKIP'
- 'ddbe76933cea0300b577095afa7459113a2d2ef02d4f300424261165ad9dee22')
+ 'ddbe76933cea0300b577095afa7459113a2d2ef02d4f300424261165ad9dee22'
+ 'fbf961b52a13105fc3190ee1213872cb421cd5351065bee423f12f8606b76373')
# shellcheck disable=SC2191 # mask \= warning.
_CMAKE_FLAGS=(
@@ -61,6 +63,7 @@ prepare() {
# git config submodule.src/dependencies/osi_clp.url
git submodule update
git apply "${srcdir}/submodule.patch"
+ git apply "${srcdir}/cuda11.patch"
# fix doc build
sed -i '/^ *install.*doc/s/doc/htmlDoc/' src/CMakeLists.txt
}