summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2018-08-31 09:17:41 +0200
committerbartus2018-08-31 09:17:41 +0200
commitf737b3a0f2fce98b8d2c60abb972a246d50201ab (patch)
tree299a158d9bdaae4dc9cad6d8f18c65ebc4356de0 /PKGBUILD
downloadaur-f737b3a0f2fce98b8d2c60abb972a246d50201ab.tar.gz
orig
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD100
1 files changed, 100 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7dfc0449edf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,100 @@
+# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
+
+_name=alice-vision
+#fragment="#commit=5bea89263bf5f3ed623b8e6e6a5f022a0ed9c1de"
+_fragment="#branch=develop"
+pkgname=${_name}
+pkgver=2.0.0.r8.g62c55519
+pkgrel=1
+pkgdesc="Photogrammetric Computer Vision Framework which provides a 3D Reconstruction and Camera Tracking algorithms"
+arch=('i686' 'x86_64')
+url="http://alicevision.github.io/"
+license=('MPL2' 'MIT')
+groups=()
+depends=('openblas-lapack' 'gflags' 'glfw-x11' 'alembic' 'boost-libs' 'openexr' 'openimageio' 'opengv-git' 'flann' 'coin-or-coinutils' 'coin-or-clp' 'coin-or-lemon' 'coin-or-osi' 'google-glog')
+makedepends=('boost' 'eigen' 'ceres-solver' 'cuda' 'git' 'cmake' 'magma')
+source=("${pkgname}::git+https://github.com/alicevision/AliceVision.git${_fragment}"
+ "osi_clp::git+https://github.com/alicevision/osi_clp.git"
+ "ute_lib::git+https://github.com/alicevision/uncertaintyTE.git"
+ "geogram::git+https://github.com/alicevision/geogram.git"
+ )
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+_CMAKE_FLAGS=(
+ -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_LIBDIR=lib
+ -DEIGEN_INCLUDE_DIR_HINTS=/usr/include/eigen3
+ -DFLANN_INCLUDE_DIR_HINTS=/usr/include/flann
+ -DCOINUTILS_INCLUDE_DIR_HINTS=/usr/include/coin
+ -DLEMON_INCLUDE_DIR_HINTS=/usr/include/lemon
+ -DCLP_INCLUDE_DIR_HINTS=/usr/include/coin
+ -DOSI_INCLUDE_DIR_HINTS=/usr/include/coin
+ -DCERES_DIR=/usr/include/ceres
+ -DMAGMA_ROOT=/opt/magma
+ -DCUDA_HOST_COMPILER=/opt/cuda/bin/gcc
+ )
+
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd ${srcdir}/${pkgname}
+ git submodule init
+ git config submodule.src/dependencies/osi_clp.url ${srcdir}/osi_clp
+ git submodule update
+}
+
+
+build() {
+ cd ${srcdir}
+
+ msg2 "Build uncertaintyTE library"
+ mkdir -p ute_build && cd ute_build
+ cmake -DCMAKE_INSTALL_PREFIX=/ -DMAGMA_ROOT=/opt/magma ../ute_lib
+ make
+ make DESTDIR="../ute_bin" install
+ cd ..
+
+ msg2 "Build geogram library"
+ mkdir -p geogram_build && cd geogram_build
+ cmake -DCMAKE_INSTALL_PREFIX=/ -DGEOGRAM_LIB_ONLY=ON -DGEOGRAM_USE_SYSTEM_GLFW3=ON -DCMAKE_BUILD_TYPE:STRING=Debug -DVORPALINE_PLATFORM:STRING=Linux64-gcc-dynamic ../geogram
+ make
+ make DESTDIR="../geogram_bin" install
+ cd ..
+
+# msg2 "Build Osi library"
+# mkdir -p osi_build && cd osi_build
+# cmake -DCMAKE_INSTALL_PREFIX=/ ../osi_clp
+# make
+# make DESTDIR="../osi_bin" install
+# cd ..
+
+ msg2 "Build AliceVision library"
+ mkdir -p build && cd build
+ cmake ${_CMAKE_FLAGS[@]} -DUNCERTAINTYTE_DIR=${srcdir}/ute_bin -DGEOGRAM_INSTALL_PREFIX=${srcdir}/geogram_bin ../${pkgname}
+ make
+}
+
+
+package() {
+ msg2 "Install uncertaintyTE"
+ cd ${srcdir}/ute_build
+ make DESTDIR=${pkgdir}/usr install
+
+ msg2 "Install geogram"
+ cd ${srcdir}/geogram_build
+ make DESTDIR=${pkgdir}/usr install
+
+ cd ${srcdir}/build
+ make DESTDIR=${pkgdir} install
+
+ #fix conflict with openmvg
+ rm ${pkgdir}/usr/lib/libvlsift.a
+}
+# vim:set ts=2 sw=2 et: