summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGoodevil952017-10-18 00:55:13 +0300
committerGoodevil952017-10-18 00:55:13 +0300
commit6e2e2afc3eaa806018f712e903f4dae0ddb7e97d (patch)
tree09d224db873b94ee8ea59a87eb637f4abe3b3826 /PKGBUILD
parentc26393b73e48aa5241f20e69c1c47c8dbb019b15 (diff)
downloadaur-6e2e2afc3eaa806018f712e903f4dae0ddb7e97d.tar.gz
Switch to Python 3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 337f6b967a66..2fedbb92798f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
pkgbase=alienfx
pkgname=alienfx
pkgver=2.0.5
-pkgrel=3
+pkgrel=4
pkgdesc="AlienFX Configuration Utility"
arch=('any')
url="https://github.com/trackmastersteve/alienfx"
license=('GPLv3')
-makedepends=('python2-setuptools')
-depends=('python2' 'python2-cairo' 'python2-gobject' 'python2-pyusb')
+makedepends=('python-setuptools')
+depends=('python' 'python-cairo' 'python-gobject' 'python-pyusb')
source=("https://github.com/trackmastersteve/${pkgbase}/archive/master.zip")
sha256sums=('3b67a8aaea8580c8ec8bfc37970e305a9a258096f66587ed8acab7d204878323')
package_alienfx() {
cd "${srcdir}/${pkgbase}-master"
- python2 setup.py clean
- python2 setup.py install --root="${pkgdir}"
+ python setup.py clean
+ python setup.py install --root="${pkgdir}"
install -Dm755 ${pkgbase}/data/etc/udev/rules.d/10-alienfx.rules ${pkgdir}/etc/udev/rules.d/10-alienfx.rules
chmod a+x ${pkgdir}/usr/share/applications/alienfx.desktop