summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2023-01-13 16:02:22 -0600
committerLuis Martinez2023-01-13 16:02:22 -0600
commitbd7a8d5fa6f152483ee1086b1fc42fc2d9292daf (patch)
tree643c59f8f3f94204ccc1a431890f0daa7332cb5c /PKGBUILD
parent439d2f26cf0b43b127c7b31d72eee2eb43eae733 (diff)
downloadaur-bd7a8d5fa6f152483ee1086b1fc42fc2d9292daf.tar.gz
update to 3.8.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60fc1344d495..d0e600ade74a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
## Credit to ayatale for the systemd and config files
pkgname=alist
-pkgver=3.7.2
+pkgver=3.8.0
pkgrel=1
pkgdesc="File list program that supports multiple storage"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'arm7vh' 'aarch64')
-url="https://github.com/xhofe/alist"
+url="https://github.com/alist-org/alist"
license=('AGPL3')
depends=('glibc')
makedepends=('go')
@@ -17,7 +17,7 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
'alist.service'
'alist.tmpfiles'
'config.json')
-sha256sums=('339277691fb372b21c5dd274c31684d65dd5b3efe9871ea0e07f7ce406775db1'
+sha256sums=('dc00c2c1282bf265be4df760a8a34d35911a0c662f1b3bcdb46a332e3eb16d0e'
'b96d55f7e83310a7556a5b023be60e12f44c484e3e136f1488d737126c9ed34f'
'48eb4f8f1070cfd2f9594fe72cb4b1a35fce091251fda11e2082f573f62ac12b'
'ba9cd5b593313183ad8c0f008a6edba539063193c416d3893a5344e104a3fff1')
@@ -38,8 +38,8 @@ build() {
## i tried, doesn't actually tag properly
go build -o build \
-ldflags="-linkmode external -extldflags \"${LDFLAGS}\" \
- -X 'github.com/Xhofe/alist/conf.GoVersion=$(go version | awk '{print $3}')' \
- -X 'github.com/Xhofe/alist/conf.GitTag=$pkgver'"
+ -X 'github.com/alist-org/alist/conf.GoVersion=$(go version | awk '{print $3}')' \
+ -X 'github.com/alist-org/alist/conf.GitTag=$pkgver'"
}
## FIXME: tests require an active connection