summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-05-28 22:22:50 -0500
committerLuis Martinez2022-05-28 22:33:42 -0500
commitffcc587b2bf412f5b0bd3b1c50dd6fa0c6fc45a4 (patch)
tree327dbc74b45d36ff43a76ef5eda3ea9d44505177 /PKGBUILD
parenta813dae45faacfcd2ba60b571b8448d89192494c (diff)
downloadaur-ffcc587b2bf412f5b0bd3b1c50dd6fa0c6fc45a4.tar.gz
update to 2.6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9851c24c1fa2..e1dd5d91c368 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
## Credit to ayatale for the systemd and config files
pkgname=alist
-pkgver=2.5.2
+pkgver=2.6.0
pkgrel=1
pkgdesc="File list program that supports multiple storage"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'arm7vh' 'aarch64')
@@ -17,7 +17,7 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
'alist.service'
'alist.tmpfiles'
'config.json')
-sha256sums=('2f62ede85e9cabb3a338e2274301ab0389a2e9d986b32247ef9d8b48cec481b0'
+sha256sums=('97e92090d01016533b8068abcf99ef0b58f4e13f45c3dee55f7f9a84af6ba32c'
'b96d55f7e83310a7556a5b023be60e12f44c484e3e136f1488d737126c9ed34f'
'48eb4f8f1070cfd2f9594fe72cb4b1a35fce091251fda11e2082f573f62ac12b'
'ba9cd5b593313183ad8c0f008a6edba539063193c416d3893a5344e104a3fff1')
@@ -38,10 +38,11 @@ build() {
## i tried, doesn't actually tag properly
go build -o build \
-ldflags="-linkmode external -extldflags \"${LDFLAGS}\" \
- -X 'github.com/Xhofe/alist/conf.gitTag=$pkgver'"
+ -X 'github.com/Xhofe/alist/conf.GoVersion=$(go version | awk '{print $3}')' \
+ -X 'github.com/Xhofe/alist/conf.GitTag=$pkgver'"
}
-## tests fail
+## tests fail to build
# check() {
# cd "$pkgname-$pkgver"
# go test ./...