summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-01-22 17:36:26 +0800
committerzxp198210052024-01-22 17:36:26 +0800
commit57c44661501ed3f2edbab13785de8fee509669b3 (patch)
tree38a601fb831c88280f90252ea9af703c52d74a8e /PKGBUILD
parentd973e0a2c74c6ec3aee9ecdb107d9af6f0ba8bcd (diff)
downloadaur-57c44661501ed3f2edbab13785de8fee509669b3.tar.gz
update to 4.11.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06e93100969f..1eefbaa55341 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=aliyun-adrive-bin
-pkgver=4.9.16
+pkgver=4.11.0
_electronversion=25
-pkgrel=2
+pkgrel=1
pkgdesc="Aliyun aDrive阿里云盘"
arch=('x86_64')
url="https://www.aliyundrive.com"
-license=('custom')
+license=('LicenseRef-custom')
conflicts=(
"${pkgname%-bin}"
"deepin-wine-adrive"
@@ -25,17 +25,18 @@ source=(
"LICENSE.html"
"${pkgname%-bin}.sh"
)
-sha256sums=('bb36e6204d6be7073ca9b13f273b55f788cd48dc9a849251a26b3239438b08d4'
+sha256sums=('507bf86e5dffe75fc9cdd8caea0e1b284dd10dfeba435e331040c305958df7a6'
'e266be0821c3ebe2521767404dccb1d4cd4000be8fe318174bdb5c70ac015509'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@appasar@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- gendesk -q -f -n --categories "Network" --name "${pkgname%-bin}阿里云盘" --exec "${pkgname%-bin}"
- mkdir -p "${srcdir}/tmp"
+ gendesk -q -f -n --categories "Network" --name "${pkgname%-bin}阿里云盘" --exec "${pkgname%-bin} %U"
+ install -Dm755 -d "${srcdir}/tmp"
7z x -aoa "${srcdir}/${pkgname%-bin}-${pkgver}.exe" -o"${srcdir}/tmp"
+ find "${srcdir}/tmp/resources" -type d -exec chmod 755 {} \;
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"