summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoey Darwish Dror2018-11-04 11:29:40 +0200
committerRoey Darwish Dror2018-11-04 11:29:40 +0200
commitaeb4ac15fc9865f29ed9901053e3fd402caf6c45 (patch)
tree6665a947cd108e9485bdf6e1c56676ae5990270d /PKGBUILD
downloadaur-aeb4ac15fc9865f29ed9901053e3fd402caf6c45.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d12dd42e7850
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Roey Darwish Dror <roey.ghost@gmail.com>
+
+pkgname=alma
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Create Arch Linux based live USB'
+arch=('x86_64')
+url='https://github.com/r-darwish/alma'
+license=('GPL3')
+makedepends=('rust')
+depends=('gptfdisk' 'parted' 'arch-install-scripts' 'dosfstools' 'btrfs-progs' 'coreutils' 'util-linux')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('a7ff39029987f7fb3ae6ad56f8b5df51c8eef849fa6f8d1c2b9b04a363fb79a8')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 target/release/$pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}