summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjuju21432020-02-26 01:51:34 -0500
committerjuju21432020-02-26 01:51:34 -0500
commit54a3eef89adede4c17e3d463fd8642aee622518f (patch)
treea3f0c25c41e248b9b5724bbb6c4a4f68020562cc /PKGBUILD
downloadaur-54a3eef89adede4c17e3d463fd8642aee622518f.tar.gz
Package aloevera
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d47b0a055e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Julien Savard <juju@juju2143.ca>
+pkgname=aloevera
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Graphical asset processing pipeline for the Commander X16"
+arch=('x86_64')
+url="https://github.com/yeastplume/aloevera"
+license=('Apache')
+depends=('gcc-libs')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/yeastplume/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('2bfda79f95d01654749003d2b3f8eb3e')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ cargo build --release --locked --all-features
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 "target/release/aloevera" "$pkgdir/usr/bin/aloevera"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ find docs -type f -exec install -Dm644 "{}" "$pkgdir/usr/share/doc/$pkgname/{}" \;
+ find samples -type f -exec install -Dm644 "{}" "$pkgdir/usr/share/doc/$pkgname/{}" \;
+}