summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDevHyperCoder2021-03-09 13:05:59 +0530
committerDevHyperCoder2021-03-09 13:05:59 +0530
commit97c21b132b49022a2a2aa81680eb6b1d4140b185 (patch)
treefda2ae233ff8f846146780983033d362706f0043 /PKGBUILD
downloadaur-alpc-git.tar.gz
v1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f7b437af859
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: DevHyperCoder <arduinoleo88 at gmail dot com>
+
+pkgname=alpc-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Aviation Language Phonetic Converter"
+arch=('x86_64')
+url="https://github.com/DevHyperCoder/alpc"
+license=('GPL')
+groups=()
+depends=()
+makedepends=('git' 'rust' 'cargo' )
+provides=("${pkgname}-git")
+conflicts=("${pkgname}-git")
+replaces=()
+backup=()
+options=()
+source=("git+https://github.com/DevHyperCoder/alpc.git")
+noextract=()
+md5sums=('SKIP')
+
+build() {
+ cd alpc
+ cargo build --release
+}
+
+
+package() {
+ cd alpc
+ install -Dm755 "target/release/alpc" \
+ -t "$pkgdir/usr/bin/"
+}