summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2023-11-24 18:43:08 -0800
committerxiota2023-11-24 18:43:08 -0800
commit2cf3167c4e9c664f97d62e1e3d6b19700268bcd4 (patch)
tree297fdc143d3b0225663e219241f1c71e1b382578 /PKGBUILD
parent52a651e077d2d0a8b0c9e7bf75d36c75f7b8c11a (diff)
downloadaur-2cf3167c4e9c664f97d62e1e3d6b19700268bcd4.tar.gz
add conflicts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 690e3d5a3b6f..5d5c926c49d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,6 +30,11 @@ _main_package() {
'qt5-tools'
)
+ conflicts=(
+ alphaplot-bin
+ alphaplot-git
+ )
+
if [ x"$pkgname" == x"$_pkgname" ] ; then
_main_stable
else
@@ -54,8 +59,8 @@ _main_stable() {
_main_git() {
makedepends+=('git')
- provides=("$_pkgname=${pkgver%%.r*}")
- conflicts=("$_pkgname")
+ provides+=("$_pkgname=${pkgver%%.r*}")
+ conflicts+=("$_pkgname")
_pkgsrc="$_pkgname"
source=("$_pkgsrc"::"git+$url.git")