summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2024-01-07 04:47:03 -0800
committerxiota2024-01-07 04:47:03 -0800
commit6c60df2b26cf6e63bd02897702e6babb734755f1 (patch)
tree4ae866ee19af14ab4b1b30b9fe6bb0cfeb3c7302 /PKGBUILD
parent2cf3167c4e9c664f97d62e1e3d6b19700268bcd4 (diff)
downloadaur-6c60df2b26cf6e63bd02897702e6babb734755f1.tar.gz
update conflicts, license
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d5c926c49d1..71466a47d297 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
# Maintainer:
# Contributor: Arun Narayanankutty <n.arun.lifescience@gmail.com>
-#: ${_pkgtype:=git}
+## useful links
+# http://alphaplot.sourceforge.net/
+# https://github.com/narunlifescience/AlphaPlot
-# basic info
+## options
+: ${_build_git:=false}
+
+[[ "${_build_git::1}" == "t" ]] && _pkgtype+="-git"
+
+## basic info
_pkgname="alphaplot"
-pkgname="$_pkgname${_pkgtype:+-$_pkgtype}"
+pkgname="$_pkgname${_pkgtype:-}"
pkgver=1.02
pkgrel=1
pkgdesc="Application for Scientific Data Analysis and Visualization, fork of SciDavis / QtiPlot"
-#url="http://alphaplot.sourceforge.net/"
url="https://github.com/narunlifescience/AlphaPlot"
arch=('i686' 'x86_64')
-license=('GPL2')
+license=('GPL-2.0-or-later')
# main package
_main_package() {
@@ -30,12 +36,9 @@ _main_package() {
'qt5-tools'
)
- conflicts=(
- alphaplot-bin
- alphaplot-git
- )
+ conflicts=(alphaplot-bin)
- if [ x"$pkgname" == x"$_pkgname" ] ; then
+ if [[ "${_build_git::1}" != "t" ]] ; then
_main_stable
else
_main_git