summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkyak2017-12-09 14:21:28 +0300
committerkyak2017-12-09 14:21:28 +0300
commit3d147a526cccbf77e1a55b5a596a2cc606711435 (patch)
treebf8b8d676927bb2bc6b6cb34082b9be1f27a0c59 /PKGBUILD
parent114fd7be0e54740d57c6077b909bfeb36205a3aa (diff)
downloadaur-3d147a526cccbf77e1a55b5a596a2cc606711435.tar.gz
Update upstream URL and package version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 7 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0283c599151..fa9445718bb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,11 @@
pkgname=alpine
pkgver=2.21
-pkgrel=1
+pkgrel=99
+pkggit=0473711
arch=("i686" "x86_64")
pkgdesc="Apache licensed PINE mail user agent"
-url="http://alpine.freeiz.com"
+url="http://repo.or.cz/alpine.git"
license=("APACHE")
depends=("libldap" "krb5" "gettext")
optdepends=("aspell: for spell-checking support"
@@ -17,24 +18,11 @@ provides=("pine")
conflicts=("pine" "re-alpine")
replaces=("pine")
options=("!makeflags")
-source=(http://alpine.freeiz.com/${pkgname}/release/src/${pkgname}-${pkgver}.tar.xz
- #ftp://ftp.cac.washington.edu/${pkgname}/${pkgname}.tar.bz2
- http://alpine.freeiz.com/${pkgname}/patches/${pkgname}-${pkgver}/all.patch.gz)
- #topal-1.patch
- #topal-2.patch)
-md5sums=("02dad85c1be80ce020206f222ecf5ac8"
- "0f44e09742442f7aa7c50b40bb957f8b")
+source=(http://repo.or.cz/alpine.git/snapshot/04737118aa1d9ad3db63fb1064267187ae871856.tar.gz)
+md5sums=("b72fc6dabf93c614cab333265581362e")
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
-# User compile time patches
-# - Eduardo Chappa patches
- patch -p1 < ../all.patch
-# - Phil Brooke patches (optional topal support)
- #patch -p1 < ../topal-1.patch
- #patch -p1 < ../topal-2.patch
-
+ cd "${srcdir}/${pkgname}-${pkggit}"
# Configure Alpine
LIBS+="-lpam -lkrb5 -lcrypto" ./configure --prefix=/usr \
@@ -48,7 +36,7 @@ build() {
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkggit}"
# Install Alpine
make DESTDIR="${pkgdir}" install