summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkyak2015-06-08 16:48:16 +0300
committerkyak2015-06-08 16:48:16 +0300
commit81ca3c8264865c96327f184d75f608614d307f8b (patch)
tree5a736f5439eeb72ecb8a21a34ebfe645c1f8fe6d /PKGBUILD
downloadaur-81ca3c8264865c96327f184d75f608614d307f8b.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06cf513759cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# -*- shell-script -*-
+#
+# Contributor: Adrian C. <anrxc..sysphere.org>
+
+pkgname=alpine
+pkgver=2.20
+pkgrel=1
+arch=("i686" "x86_64")
+pkgdesc="Apache licensed PINE mail user agent"
+url="http://patches.freeiz.com/alpine/"
+license=("APACHE")
+depends=("libldap" "krb5" "gettext")
+optdepends=("aspell: for spell-checking support"
+ "hunspell: for spell-checking support"
+ "topal: glue program that links GnuPG and alpine")
+provides=("pine")
+conflicts=("pine" "re-alpine")
+replaces=("pine")
+options=("!makeflags")
+source=(http://patches.freeiz.com/${pkgname}/release/src/${pkgname}-${pkgver}.tar.xz
+ #ftp://ftp.cac.washington.edu/${pkgname}/${pkgname}.tar.bz2
+ http://patches.freeiz.com/${pkgname}/patches/${pkgname}-${pkgver}/all.patch.gz
+ topal-1.patch
+ topal-2.patch)
+md5sums=("043b67666af73b26f9627ad97e2aaf92"
+ "d2c2576b58f65566ccf1a9d5add0f14a"
+ "ce47b232339b251c74dc56de73513101"
+ "e53177e123ec68fc77d55f60cd9eba9f")
+
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+# User compile time patches
+# - Eduardo Chappa patches
+ patch -p1 < ../all.patch
+# - Phil Brooke patches (optional topal support)
+ #patch -p1 < ../topal-1.patch
+ #patch -p1 < ../topal-2.patch
+
+
+# Configure Alpine
+ LIBS+="-lpam -lkrb5 -lcrypto" ./configure --prefix=/usr \
+ --without-passfile --without-tcl --disable-shared \
+ --with-system-pinerc=/etc/${pkgname}.d/pine.conf \
+ --with-system-fixed-pinerc=/etc/${pkgname}.d/pine.conf.fixed
+
+# Build Alpine
+ make
+}
+
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+# Install Alpine
+ make DESTDIR="${pkgdir}" install
+}