summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2024-03-26 17:56:07 -0600
committerMark Wagie2024-03-26 17:56:07 -0600
commit659f5fed909c5f85485fe991d23890e145836b58 (patch)
tree9abee116fa13bb437a0caf1a3687d0cb3c1f43e4 /PKGBUILD
parenta8bb069a7ea6be0ee7e04fc74e221f6d51499224 (diff)
downloadaur-alpm_octopi_utils.tar.gz
adopt package ...
- correct arch - add Makefile patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 020f24338b3f..3a20150f94d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,34 @@
-# Maintainer: MatMoul <matmoul at the google email domain which is .com>
-
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+# Contributor: MatMoul <matmoul at the google email domain which is .com>
pkgname=alpm_octopi_utils
pkgver=1.0.2
-pkgrel=4
+pkgrel=5
pkgdesc="Alpm utils for Octopi"
-arch=('any')
-url="https://tintaescura.com/projects/octopi/"
-license=('GPL3')
+arch=('x86_64')
+url="https://github.com/aarnt/alpm_octopi_utils"
+license=('GPL-3.0-or-later')
depends=('pacman-contrib')
makedepends=('git' 'vala')
-source=("git+https://github.com/aarnt/alpm_octopi_utils.git#commit=1e735c3a27803ca5b6470e946f9cac708143dfd9")
-sha256sums=('006ba126ed4ed99de6f3be8fba152cdeebd1048724d902d7e98f1a9eb98d4ca4')
+provides=('alpm-octopi-utils')
+_commit=1e735c3a27803ca5b6470e946f9cac708143dfd9 # master
+source=("git+https://github.com/aarnt/alpm_octopi_utils.git#commit=$_commit"
+ 'https://github.com/aarnt/alpm_octopi_utils/pull/4.patch')
+sha256sums=('SKIP'
+ 'c117f3a86f6428f671723b921229fdfe3e61b057efae1e0b3b2b1a2993ef8842')
+
+prepare() {
+ cd alpm_octopi_utils
+
+ # Add DESTDIR to Makefile
+ patch -Np1 -i ../4.patch
+}
build() {
- cd "$pkgname"
- make
+ cd alpm_octopi_utils
+ make
}
package() {
- cd "$pkgname"
- install -D -m755 src/libalpm_octopi_utils.so "$pkgdir"/usr/lib/libalpm_octopi_utils.so
- install -D -m644 src/libalpm_octopi_utils.pc "$pkgdir"/usr/lib/pkgconfig/libalpm_octopi_utils.pc
- install -D -m644 src/alpm_octopi_utils.h "$pkgdir"/usr/include/alpm_octopi_utils.h
+ cd alpm_octopi_utils
+ make DESTDIR="$pkgdir" install
}