summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJia Li2016-08-16 14:22:52 -0400
committerJia Li2016-08-16 14:22:52 -0400
commitf19dfb476673461af3563bd169545b9142f448b4 (patch)
tree01be9f282cf159ae8ac7495b19fa441010d604ae /PKGBUILD
downloadaur-f19dfb476673461af3563bd169545b9142f448b4.tar.gz
Init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..630074f54146
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jia Li <lijia1608@gmail.com>
+pkgname=alpscore-openmpi-git
+pkgver=0.5.4.r49.g3211c91
+pkgrel=1
+pkgdesc="ALPS Core libraries for numerical simulations of condensed matter systems."
+arch=(i686 x86_64)
+url="http://alpscore.org"
+license=('GPL2')
+depends=('cmake' 'boost' 'hdf5' 'openmpi')
+makedepends=(git)
+provides=(${pkgname%-*-*}=$pkgver)
+conflicts=(alpscore alpscore-openmpi alpscore-git alps)
+source=($pkgname::git+https://github.com/ALPSCore/ALPSCore.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ mkdir -p build
+ cd build
+ CC=mpicc CXX=mpicxx cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DDocumentation=OFF -DTesting=OFF ..
+ make
+}
+
+package() {
+ cd "$pkgname/build"
+ make DESTDIR="$pkgdir/" install
+}