summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2021-01-04 23:04:34 -0500
committerVincent Grande2021-01-04 23:04:34 -0500
commitb81626fd2411d0c1ae00efa6b564d574659f9b1f (patch)
tree15c9f2af2fa2b17c7d441f3e2a7a1e22e1797468 /PKGBUILD
downloadaur-b81626fd2411d0c1ae00efa6b564d574659f9b1f.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e1953a7c52e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: David Runge <dvzrv@archlinux.org>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
+pkgname=alsa-utils-git
+pkgver=1.2.4
+pkgrel=1
+pkgdesc="Advanced Linux Sound Architecture - Utilities"
+arch=('x86_64')
+url="https://www.alsa-project.org"
+license=('GPL2')
+depends=('glibc' 'pciutils' 'psmisc')
+makedepends=('alsa-lib' 'docbook-xsl' 'fftw' 'libsamplerate' 'ncurses'
+'python-docutils' 'systemd' 'xmlto')
+optdepends=('fftw: for alsabat')
+# we require /var/lib/alsa for state file
+options=(emptydirs)
+source=("git+https://github.com/alsa-project/alsa-utils.git")
+sha512sums=('SKIP')
+#validpgpkeys=('F04DF50737AC1A884C4B3D718380596DA6E59C91') # ALSA Release Team (Package Signing Key v1) <release@alsa-project.org>
+
+prepare() {
+ cd alsa-utils
+ autoreconf -vfi
+}
+
+build() {
+ cd alsa-utils
+ ./configure --prefix=/usr \
+ --disable-alsaconf \
+ --sbindir=/usr/bin \
+ --with-udev-rules-dir=/usr/lib/udev/rules.d \
+ --with-systemdsystemunitdir=/usr/lib/systemd/system
+ make
+}
+
+package() {
+ depends+=('libasound.so' 'libatopology.so' 'libformw.so' 'libmenuw.so'
+ 'libncursesw.so' 'libpanelw.so' 'libsamplerate.so')
+ cd alsa-utils
+ make DESTDIR="${pkgdir}" install
+ install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/alsa-utils"
+ # dir where to save ALSA state
+ install -d "${pkgdir}/var/lib/alsa"
+}