summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoroberon20072016-01-09 19:48:55 +0100
committeroberon20072016-01-09 19:48:55 +0100
commite011f7458af4fd26e8bb298cb4fef1dac3fe945c (patch)
treefe295b0ff071f373e80fd2e833502eeb4d8835f5 /PKGBUILD
downloadaur-e011f7458af4fd26e8bb298cb4fef1dac3fe945c.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7204e20780b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Bernhard Landauer <oberon@manjaro.org>
+
+pkgname=alternating-layouts-git
+pkgver=r20.179edd6
+pkgrel=1
+pkgdesc="Alternating split directions for the i3-wm"
+_repo=i3-alternating-layout
+url="github.com/olemartinorg/$_repo"
+arch=('any')
+license=('MIT')
+depends=('i3-wm'
+ 'python-i3-git'
+ 'xorg-utils')
+conflicts=('alternating-layouts')
+makedepends=('git')
+install=alternating-layouts.install
+source=("git://$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_repo
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $_repo
+ install -Dm 755 alternating_layouts.py $pkgdir/usr/bin/alternating_layouts.py
+}