summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKurobac2018-07-15 01:16:03 +0800
committerKurobac2018-07-15 01:16:03 +0800
commitc1cea1928571be3e09ecf012ebd7547538ac9261 (patch)
treefd92768955a9b6f2549472ec44e829de52f8b2e3 /PKGBUILD
parent9c4fe0cb3d5eb48a9d5a40f4bee3a7e625c72c5f (diff)
downloadaur-c1cea1928571be3e09ecf012ebd7547538ac9261.tar.gz
fix softlinks in /usr/src/
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 19fd11506bcd..bcc6108c5894 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,9 @@
+# Maintainer: Kurobac <kurobac(at)foxmail(dot)com>
+# Contributor: angelsl
+
_pkgbase=alx-wol
pkgname=${_pkgbase}-dkms
-pkgver=2
+pkgver=3
pkgrel=1
pkgdesc="The alx kernel module with a patch enabling WoL applied"
license=("GPL")
@@ -24,5 +27,5 @@ sha256sums=('b4f78f21c3485680f1533002771a268ce869863f8684c0fc67e8a938a6276ae9'
package() {
local dest="$pkgdir/usr/src/${_pkgbase}-$pkgver"
mkdir -p $dest
- cp -a Kbuild dkms.conf alx.h ethtool.c hw.c hw.h main.c reg.h $dest
+ cp --preserve=all Kbuild dkms.conf alx.h ethtool.c hw.c hw.h main.c reg.h $dest
}