summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoredward-p2019-06-15 01:39:28 +0800
committeredward-p2019-06-15 01:39:28 +0800
commitdc62484eb8aa5e983b70cecf5936ac4c44c34e41 (patch)
tree7eaebc3198dffb90cb4565e7f36b4b1ac3a41227 /PKGBUILD
parentc1cea1928571be3e09ecf012ebd7547538ac9261 (diff)
downloadaur-dc62484eb8aa5e983b70cecf5936ac4c44c34e41.tar.gz
Using latest alx driver from https://git.archlinux.org/linux.git
Enable WOL by 000-enable-alx-wol.patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 23 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bcc6108c5894..450511311f10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Kurobac <kurobac(at)foxmail(dot)com>
-# Contributor: angelsl
+# Maintainer: Edward Pacman < edward(at)edward(minus)p(dot)xyz >
+# Contributor: Kurobac <kurobac(at)foxmail(dot)com>
_pkgbase=alx-wol
pkgname=${_pkgbase}-dkms
-pkgver=3
+pkgver=4
pkgrel=1
pkgdesc="The alx kernel module with a patch enabling WoL applied"
license=("GPL")
@@ -12,20 +12,32 @@ depends=('glibc' 'dkms')
optdepends=('linux-headers: Needed for build the module for Arch kernel'
'linux-lts-headers: Needed for build the module for LTS Arch kernel'
'linux-zen-headers: Needed for build the module for ZEN Arch kernel')
-source=(https://raw.githubusercontent.com/angelsl/linux/alx-wol/drivers/net/ethernet/atheros/alx/{alx.h,ethtool.c,hw.c,hw.h,main.c,reg.h}
+source=(https://git.archlinux.org/linux.git/plain/drivers/net/ethernet/atheros/alx/{alx.h,ethtool.c,hw.c,hw.h,main.c,reg.h}
+ 000-enable-alx-wol.patch
Kbuild
dkms.conf)
-sha256sums=('b4f78f21c3485680f1533002771a268ce869863f8684c0fc67e8a938a6276ae9'
- '922f2837b5b7bb51bb112e53a22ee4883acfcb53b83c4b79bf9d7a99d032f6fd'
- 'fa609e88b05e1597f9734c4b625a00771cf4d70aa65b054664b1eda3c29dac77'
- 'a0b0b41752a8b69a5ef31574501897c3631e007ea8f8232732df1e2ebdf28e6f'
- 'af49b2027f8d3ee2f2480fad79b3867054d73e6537612724599eed6bcd2bec6d'
- '88a23ab8e6fe814efe81910bd8806f5988d367a628458154edaebdf4ccbe4902'
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '3d0549a45f78595bfdcd9d6e14f115ecc159583a39d51b23aa3c9852630823d0'
'8a62bb5adf6e554f470f88f8da58da0ce05cb8276ab56fb45ed5d31c71665d39'
'f3aefc85fd246a74ee2be831c15b6440d22c497e84fba1f57e152c82f2946d1a')
+prepare(){
+ mkdir "${srcdir}/workdir"
+ cd "${srcdir}/workdir"
+ cp "${srcdir}/"{alx.h,ethtool.c,hw.c,hw.h,main.c,reg.h} .
+ patch -p1 < ../000-enable-alx-wol.patch
+}
+
package() {
local dest="$pkgdir/usr/src/${_pkgbase}-$pkgver"
mkdir -p $dest
- cp --preserve=all Kbuild dkms.conf alx.h ethtool.c hw.c hw.h main.c reg.h $dest
+ cd "${srcdir}/workdir/"
+ cp --preserve=all {alx.h,ethtool.c,hw.c,hw.h,main.c,reg.h} $dest
+ cd "${srcdir}"
+ cp --preserve=all Kbuild dkms.conf $dest
}