summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMiepee2021-09-11 20:33:36 +0200
committerMiepee2021-09-11 20:33:36 +0200
commit6f6a5d2bab89b594d24387be01d196e41acb61dd (patch)
treec0b31daaf5bfe90ad1d5322b7ab083935ec019ca /PKGBUILD
parentdf5dbe370528b4bc5e0c2ba8747238aa9df1a207 (diff)
downloadaur-6f6a5d2bab89b594d24387be01d196e41acb61dd.tar.gz
make pkgbuild cleaner
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 13 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ae189121e29..449eb99076b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Miepee <janbidler00 at tutanota dot com>
pkgname=am2rlauncher-git
-pkgver=2.1.0.r4.137c25b
-pkgrel=2
+pkgver=2.1.2.r5.200cc93
+pkgrel=1
pkgdesc="Application for installing the latest Community Updates, APKs and Mods for AM2R."
arch=(x86_64)
url="https://github.com/AM2R-Community-Developers/AM2RLauncher"
@@ -34,19 +34,18 @@ package() {
mkdir -p "$pkgdir/opt/am2rlauncher/"
cp -Rf AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/bin/release/net5.0/ubuntu.18.04-x64/publish/* "$pkgdir/opt/am2rlauncher/"
- cp -f "AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/icon64.ico" $pkgdir/opt/am2rlauncher/AM2RLauncher.ico
- cd "$pkgdir/usr/bin/"
- ln -sf "/opt/am2rlauncher/AM2RLauncher"
+ cp -f "AM2RLauncher/AM2RLauncher/AM2RLauncher.Gtk/icon64.ico" "$pkgdir/opt/am2rlauncher/AM2RLauncher.ico"
+ ln -sf "$pkgdir/opt/am2rlauncher/AM2RLauncher" "$pkgdir/usr/bin/AM2RLauncher"
# Adding desktop entry
mkdir -p "$pkgdir/usr/share/applications/"
- echo "[Desktop Entry]
-Type=Application
-Categories=Game
-Encoding=UTF-8
-Name=AM2RLauncher
-Comment=A front-end application that simplifies installing the latest AM2R-Community-Updates, creating APKs for Android use, as well as Mods for AM2R.
-Exec=AM2RLauncher
-Icon=/opt/am2rlauncher/AM2RLauncher.ico
-Terminal=false" > $pkgdir/usr/share/applications/am2rlauncher.desktop
+ echo "[Desktop Entry]
+ Type=Application
+ Categories=Game
+ Encoding=UTF-8
+ Name=AM2RLauncher
+ Comment=A front-end application that simplifies installing the latest AM2R-Community-Updates, creating APKs for Android use, as well as Mods for AM2R.
+ Exec=AM2RLauncher
+ Icon=/opt/am2rlauncher/AM2RLauncher.ico
+ Terminal=false" > "$pkgdir/usr/share/applications/am2rlauncher.desktop"
}