summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFredy García2022-03-08 14:55:34 -0500
committerFredy García2022-03-08 14:55:34 -0500
commit79b016da70d65dd42e460b52e7ba4443029693a7 (patch)
tree06e2609b1b29301ab07c2568c663e1da56d80ff7 /PKGBUILD
parent10d706f0181446e17f5a9c1bd06eb9b6636507a0 (diff)
downloadaur-79b016da70d65dd42e460b52e7ba4443029693a7.tar.gz
Support for FFMPEG 5.0 and fixing bug in CMakeLists generating config.h file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d637faa66480..d698de04d448 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=amarok
pkgver=2.9.71
-pkgrel=1
+pkgrel=2
pkgdesc="The powerful music player for KDE"
arch=("x86_64")
url="http://${pkgname}.kde.org/"
@@ -17,12 +17,21 @@ optdepends=(
"ifuse: support for Apple iPod Touch and iPhone"
"loudmouth: backend needed by mp3tunes for syncing"
)
-source=("https://download.kde.org/unstable/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.xz")
-sha256sums=("6a404829d336f69415fb6bb4ea1d5566759fb95e3e84f904ee9ef82a7be4e84f")
+source=(
+ "https://download.kde.org/unstable/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.xz"
+ "ffmpeg5_cmakelist_configure.patch::https://invent.kde.org/multimedia/amarok/-/merge_requests/45.diff"
+)
+sha256sums=(
+ "6a404829d336f69415fb6bb4ea1d5566759fb95e3e84f904ee9ef82a7be4e84f"
+ "77a1f8cbc7f786e5616fbb5922dcf193614dbdf2a1d3fa2b2196c3fdb2f0387b"
+)
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ # Patching to fix FFMPEG5 and CMakeLists bug with config.h definition position https://invent.kde.org/multimedia/amarok/-/merge_requests/45
+ patch -Np1 -i "${srcdir}/ffmpeg5_cmakelist_configure.patch"
+
mkdir -p "${srcdir}/${pkgname}-${pkgver}/build"
}