summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMihkel Tõnnov2024-02-04 14:11:11 +0100
committerMihkel Tõnnov2024-02-04 14:19:29 +0100
commitf3d14e115601ecdfa06f9ad533684e892f7e4a72 (patch)
treeae903bc2f2caba94dbdfb972a5e02fae5c88fd17 /PKGBUILD
parent3480c2e50f3ef55cf0331077b45c0c55f9d48a38 (diff)
downloadaur-f3d14e115601ecdfa06f9ad533684e892f7e4a72.tar.gz
Fix build with TagLib 2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 34 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a7f77f832b2..14277208248f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,58 @@
-# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Maintainer: Mihkel Tõnnov <mihhkel-at-gmail-dot-com>
+# Contributor: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
# Contributor: Evert Vorster <evorster-at-gmail-dot-com>
# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
# Contributor: Jakub Schmidtke <sjakub-at-gmail-dot-com>
# Contributor: Maël Kerbiriou <mael.kerbiriou-at-free-dot-fr>
pkgname=amarok-git
-pkgver=2.9.71.r309.g26fed89
-pkgrel=1
+pkgver=2.9.71.r319.b592705a6c
+pkgrel=2
pkgdesc="The powerful music player for KDE"
arch=("i686" "x86_64")
url="http://amarok.kde.org"
-license=('GPL2' 'LGPL2.1' 'FDL')
-depends=('threadweaver5' 'qt5-webengine' 'phonon-qt5' 'qt5-declarative'
- 'kcmutils5' 'knewstuff5' 'ktexteditor5' 'kdnssd5'
- 'libmariadbclient' 'fftw'
- 'liblastfm-qt5' 'ffmpeg' 'kirigami2')
-makedepends=('git' 'extra-cmake-modules' 'kdoctools5')
-optdepends=("libgpod: support for Apple iPod audio devices"
- "libmtp: support for portable media devices"
+license=("GPL2" "LGPL2.1" "FDL")
+depends=("threadweaver5" "qt5-webengine" "phonon-qt5" "qt5-declarative" "qt5-script"
+ "kcmutils5" "knewstuff5" "ktexteditor5" "kdnssd5" "kirigami2"
+ "mariadb" "libmariadbclient" "fftw" "liblastfm-qt5" "ffmpeg" "taglib" "libofa")
+makedepends=("git" "extra-cmake-modules" "kdoctools5" "gdk-pixbuf2" "knotifyconfig5"
+ "libmtp" "libgpod" "loudmouth" "libmygpo-qt5")
+optdepends=("libmtp: support for portable media devices"
+ "ifuse: support for Apple iPod Touch and iPhone"
+ "libgpod: support for Apple iPod audio devices"
"loudmouth: backend needed by mp3tunes for syncing"
"libmygpo-qt5: gpodder.net Internet Service"
- "gmock: tests"
- "taglib-extras: Additional taglib functionality")
-conflicts=('amarok')
-provides=('amarok')
-source=(git+https://invent.kde.org/multimedia/amarok.git)
-sha512sums=('SKIP')
+ "gmock: tests")
+conflicts=("amarok" "taglib-extras")
+provides=("amarok")
+source=("git+https://invent.kde.org/multimedia/amarok.git"
+ "taglib2.diff")
+sha512sums=("SKIP"
+ "8f57e97c334e09c490b2c38c6ecbeda2fbf05d109098a10e924fa72ab13768425c9b89f5ecf47ba197169854f9e19dd626c4454d7500ea36d72805555b852f8e")
pkgver() {
- cd amarok
- git describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/amarok"
+ set -o pipefail
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/amarok"
+ patch -Np1 -i "${srcdir}/taglib2.diff"
+ mkdir -p "${srcdir}/build"
}
build() {
- mkdir build
- cd build
- cmake ../amarok \
+ cd "${srcdir}/build"
+ cmake "${srcdir}/amarok" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_TESTING=OFF \
-DCMAKE_BUILD_TYPE=Release
make
}
package(){
- cd build
+ cd "${srcdir}/build"
make "DESTDIR=${pkgdir}" install
-}
+} \ No newline at end of file