summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNekmo2018-02-04 22:55:36 +0100
committerNekmo2018-02-04 22:55:36 +0100
commit573514fbe30eb89d2ec319311f7b07b82c0f0cfd (patch)
tree5d4f2413bcee2592327c98a72590f756226730a9 /PKGBUILD
downloadaur-573514fbe30eb89d2ec319311f7b07b82c0f0cfd.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a72092240e08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# See http://wiki.archlinux.org/index.php/Python_Package_Guidelines for more
+# information on Python packaging.
+
+# Maintainer: Nekmo <contacto@nekmo.com>
+_pkgname="amazon-dash"
+pkgname="${_pkgname}-git"
+source=("$_pkgname::git+https://github.com/Nekmo/amazon-dash.git#branch=v0.4.0")
+pkgver=v0.3.3.r21.g6bf9a33
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+pkgrel=1
+pkgdesc="Hack your Amazon Dash to run what you want."
+arch=("any")
+url="https://github.com/Nekmo/amazon-dash"
+license=('MIT')
+groups=()
+depends=('scapy3k' 'python-yaml' 'python-jsonschema' 'python-requests' 'python-click' 'python-click-default-group')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=amazon-dash.install
+md5sums=("SKIP")
+#source=()
+#md5sums=()
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}