summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorD. Can Celasun2021-08-26 05:26:45 +0100
committerD. Can Celasun2021-08-26 05:26:45 +0100
commit76c5a2f8b17603659d024dd86b10b98316a850fd (patch)
treef3a27940efcad702ef8bb41739bdbc5791a78120 /PKGBUILD
parentea74a3b2d058d5d02539d356c6ba37d0a8c1518e (diff)
downloadaur-76c5a2f8b17603659d024dd86b10b98316a850fd.tar.gz
[amazon-ecr-credential-helper] Update GOFLAGS
This follows Go packaging guidelines [1]. [1] https://wiki.archlinux.org/title/Go_package_guidelines#Flags_and_build_options
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 81219b50e513..dcc2960638f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=amazon-ecr-credential-helper
pkgver=0.5.0
-pkgrel=2
+pkgrel=3
_commit=b19192b6522b2da02d14ec394c331f3b1a70efe2
pkgdesc="A credential helper for the Docker daemon that makes it easier to use Amazon EC2 Container Registry."
url='https://github.com/awslabs/amazon-ecr-credential-helper'
@@ -28,6 +28,7 @@ prepare() {
build() {
msg2 "Build program"
cd "${srcdir}/src/${_gourl}/${pkgname}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
GOPATH="${srcdir}" PATH="${srcdir}/bin:${PATH}" make
}