summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSteve Engledow2019-12-19 15:31:17 +0000
committerSteve Engledow2019-12-19 15:59:35 +0000
commit6a9d3340960445c2c341b005b00c82a6e7ab5f1a (patch)
tree1d7df88302900debe791f696996b327ebfe8012a /PKGBUILD
downloadaur-6a9d3340960445c2c341b005b00c82a6e7ab5f1a.tar.gz
Add PKGBUILD and .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d3e1c844bed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Steve Engledow <steve@engledow.me>
+pkgname=amazon-workspaces-bin
+pkgver=latest
+pkgrel=1
+pkgdesc="Amazon Workspace Client"
+arch=('i686' 'x86_64')
+url="https://clients.amazonworkspaces.com/"
+license=('non-free')
+depends=(
+)
+options=('staticlibs')
+makedepends=(
+ 'binutils'
+ 'tar'
+)
+source=("workspaces-client.deb::https://d3nt0h4h6pmmc4.cloudfront.net/ubuntu/dists/bionic/main/binary-amd64/workspacesclient_3.0.0.200_amd64.deb")
+sha1sums=("SKIP")
+
+build() {
+ cd "$srcdir"
+ ar x workspaces-client.deb
+ tar axvf data.tar.xz
+}
+
+package() {
+ mkdir -p $pkgdir/usr/share/amazon-workspaces
+ mkdir -p $pkgdir/usr/bin
+
+ # Icons
+ cp -a $srcdir/usr/share/* $pkgdir/usr/share/
+
+ # Binary
+ cp -a $srcdir/opt/workspacesclient/* $pkgdir/usr/share/amazon-workspaces/
+
+ # Launcher
+ ln -s $pkgdir/usr/share/amazon-workspaces/workspacesclient $pkgdir/usr/bin/amazon-workspaces
+}