summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSteve Engledow2020-07-29 12:12:32 +0100
committerSteve Engledow2020-07-29 12:12:32 +0100
commit959c6d667f7dc46ba16c23eb6f498ecfd54a40d8 (patch)
tree9d71a33d1ad0ce182ab665c32945f800a752429d /PKGBUILD
parent6eb96570046c57ff69c10af54393323a32879a76 (diff)
downloadaur-959c6d667f7dc46ba16c23eb6f498ecfd54a40d8.tar.gz
Fix the .desktop file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e71c188729a..94cdf7499130 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Steve Engledow <steve@engledow.me>
pkgname=amazon-workspaces-bin
pkgver=3.0.8.529
-pkgrel=2
+pkgrel=3
pkgdesc='Amazon Workspace Client'
arch=('i686' 'x86_64')
url="https://clients.amazonworkspaces.com/"
@@ -22,6 +22,10 @@ build() {
cd "$srcdir"
ar x "$pkgname-$pkgver.deb"
tar axvf data.tar.xz
+
+ # Fix the .desktop entry
+ sed -i -e 's/\/opt\/workspacesclient/\/usr\/share\/amazon-workspaces/' $srcdir/usr/share/applications/workspacesclient.desktop
+ mv $srcdir/usr/share/applications/workspacesclient.desktop $srcdir/usr/share/applications/amazon-workspaces.desktop
}
package() {