aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFaustino Aguilar2017-07-22 00:01:31 -0500
committerFaustino Aguilar2017-07-22 00:01:31 -0500
commitc4111319f7efa0619143215ecdb169499ea0b25f (patch)
tree4c4d04965140cdefc1d35081786ac59ae04e7c3f /PKGBUILD
downloadaur-c4111319f7efa0619143215ecdb169499ea0b25f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe1067c1acf2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Faustino Aguilar <faustinoaq.github.io>
+pkgname=amber_cmd
+pkgver=0.1.17
+pkgrel=1
+pkgdesc="CLI for Amber framework that makes interfacing with your file system and applications much smoother."
+arch=(i686 x86_64)
+url='https://github.com/Amber-Crystal/amber_cmd'
+license=(MIT)
+depends=('crystal' 'readline' 'shards')
+makedepends=('llvm')
+source=("https://github.com/Amber-Crystal/amber_cmd/archive/v$pkgver.tar.gz")
+sha256sums=('721d8d9dbd13df2187e7d6ffad5b00894908dd18dbc90d65c85272422f84f4a5')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make build
+ crystal eval 'STDIN.blocking = true'
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ crystal spec --no-debug -p
+ crystal eval 'STDIN.blocking = true'
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 bin/amber "$pkgdir/usr/bin/amber"
+}