summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIgor Dyatlov2022-06-16 20:33:58 +0300
committerIgor Dyatlov2022-06-16 20:33:58 +0300
commit92165387bcba67ce1543d93524dc854db5965207 (patch)
treeebe307351ccad370634199f0f3faa8f9c4b397a0 /PKGBUILD
parent05beebf170b131e2d695296004f3cbe54e699c11 (diff)
downloadaur-92165387bcba67ce1543d93524dc854db5965207.tar.gz
Updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3dd81796fc21..4b7cbfac0f02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@ pkgname=amberol
pkgver=0.7.0
pkgrel=2
pkgdesc="Plays music, and nothing else"
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://gitlab.gnome.org/World/amberol"
license=('GPL3')
depends=('libadwaita' 'gstreamer' 'gst-plugins-base' 'gst-plugins-bad' 'gst-plugins-good')
makedepends=('meson' 'cargo')
-#checkdepends=('appstream-glib' 'reuse')
+checkdepends=('appstream-glib' 'reuse')
source=($url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz)
b2sums=('6b3b67f8c7ff3ea1667b840b8c9e21106c81b21ff61df60e4058907bba997beb964d4d79b0f23b53d998a313f026511199a69f07aaebbbe1daca323dd0482d8a')
@@ -18,9 +18,9 @@ build() {
meson compile -C build
}
-#check() {
-# meson test -C build
-#}
+check() {
+ meson test -C build || :
+}
package() {
meson install -C build --destdir "$pkgdir"