summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIgor Dyatlov2022-04-11 22:37:13 +0300
committerIgor Dyatlov2022-04-11 22:37:13 +0300
commita34f157ee697420e787dc7983ed99ebd174ee3b9 (patch)
treeaabc9eb3a2bdef173aa5c88915f148a91af3084c /PKGBUILD
downloadaur-a34f157ee697420e787dc7983ed99ebd174ee3b9.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62cfd9b90420
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=amberol
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Plays music, and nothing else"
+arch=('x86_64')
+url="https://gitlab.gnome.org/ebassi/amberol"
+license=('GPL3')
+depends=('libadwaita' 'gstreamer')
+makedepends=('meson')
+checkdepends=('appstream-glib')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=($url/-/archive/$pkgver/$pkgname-$pkgver.tar)
+b2sums=('398102908f6c2806c38eb3b80f680593ae0f7e1969a4cde8e4646043ae5ea6ec7c4b34216b63d17a8214e6a53a9fe79b69aa7c869d9c157cc9ee0d432bbac2aa')
+
+build() {
+ arch-meson "$pkgname-$pkgver" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}