summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBaytars2020-03-17 10:20:54 +0800
committerBaytars2020-03-17 10:20:54 +0800
commit10ec23de2959c40076776997e5899d58fabdf055 (patch)
treedb69ec8cd1eb78afd09521339c744bbd59d9bdf3 /PKGBUILD
parentf7f6cb990f69b7c5cbef15347079cf573fa9100c (diff)
downloadaur-10ec23de2959c40076776997e5899d58fabdf055.tar.gz
Fixed write permission issue in libltdl
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8767ccc54cb8..902b8e3608b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@ arch=('x86_64')
url="https://www.ambulantplayer.org/"
_git=https://e.coding.net/Baytars/ambulant-2.6.git
license=('LGPL')
-depends=('ed' 'python2' 'python' 'ffmpeg')
-makedepends=('make' 'automake' 'git' 'autoconf')
+depends=('ffmpeg')
+makedepends=('make' 'automake' 'git' 'autoconf' 'ed' 'python2' 'python')
provides=('AmbulantPlayer_gtk')
conflicts=('AmbulantPlayer_gtk')
install=AmbulantPlayer_gtk.install
@@ -27,7 +27,10 @@ build() {
cd ../
./autogen.sh
./configure
- sudo make
+ cfgPath=`readlink ./libltdl/config-h.in`
+ rm ./libltdl/config-h.in
+ cp $cfgPath ./libltdl/config-h.in
+ make
}
package() {