summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDenis Demidov2015-06-09 22:02:08 +0300
committerDenis Demidov2015-06-09 22:02:08 +0300
commitbb8f2c5b4955b455591ed95d0c849a354cfe01c7 (patch)
tree2d48309083d3f05200124b06880c1d4a8ad8d172 /PKGBUILD
downloadaur-bb8f2c5b4955b455591ed95d0c849a354cfe01c7.tar.gz
Moving to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74dde3a5d880
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Denis Demidov <dennis.demidov@gmail.com>
+
+pkgname=amgcl-git
+pkgver=20150609
+pkgrel=2
+pkgdesc='C++ library for solving large sparse linear systems with algebraic multigrid method'
+arch=('i686' 'x86_64')
+url='http://github.com/ddemidov/amgcl'
+license=('MIT')
+depends=('boost-libs')
+optdepeneds=('vexcl-git': 'vexcl backend'
+ 'hpx-git': 'HPX backend'
+ 'openmpi: distributed memory solver')
+provides=('amgcl')
+makedepends=('git' 'cmake' 'boost')
+source=()
+
+_gitroot='git://github.com/ddemidov/amgcl.git'
+_gitname='amgcl'
+
+package() {
+ msg "Connecting to GIT server..."
+ rm -rf $_gitname
+ git clone --depth=1 $_gitroot
+ msg "GIT checkout done or server timeout"
+
+ cd $_gitname
+ install -d "$pkgdir/usr/include/amgcl"
+ find amgcl -type f -exec install -Dm644 '{}' "$pkgdir/usr/include/amgcl/" ';' || return 1
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$_gitname/LICENSE.md" || return 1
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$_gitname/README.md" || return 1
+}