summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorquellen2017-05-29 23:47:50 +0200
committerquellen2017-05-29 23:47:50 +0200
commitbe8e00367989979a29ba745ed0ac75516eae96e4 (patch)
tree21930e35964806d602f2710f41a6f834c5afd4cb /PKGBUILD
downloadaur-be8e00367989979a29ba745ed0ac75516eae96e4.tar.gz
useful commit message
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63219ac857d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: quellen <lodgerz@gmail.com>
+pkgname=amitools
+pkgver=r.
+pkgrel=1
+pkgdesc="Various AmigaOS tools for other platforms"
+arch=('i686' 'x86_64')
+url="https://github.com/cnvogelg/amitools"
+license=('GPL')
+depends=('python-lhafile' 'python2' 'cython2')
+source=("git+https://github.com/cnvogelg/amitools.git")
+md5sums=('SKIP')
+sha256sums=('SKIP')
+pkgver() {
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+build() {
+ cd "${pkgname}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${pkgname}"
+ python2 setup.py install --root="$pkgdir/" --prefix=/usr
+} \ No newline at end of file