summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormirkobrombin2021-05-23 11:25:16 +0200
committermirkobrombin2021-05-23 11:25:16 +0200
commit0ca39621fa2f7cb5d5b4bd33d3f8fb9b46bb37bc (patch)
treecdbd6dc8f21f1cb47231720713670c664f176f8c /PKGBUILD
downloadaur-0ca39621fa2f7cb5d5b4bd33d3f8fb9b46bb37bc.tar.gz
Release 1.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..402908257554
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintaner: Mirko Brombin <send@mirko.pm>
+# Contributor: Mirko Brombin <send@mirko.pm>
+
+pkgname=amusiz
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='A GTK Amazon Music client for Linux'
+arch=('x86_64')
+url="https://github.com/mirkobrombin/Amusiz"
+license=('GPL3')
+depends=('hicolor-icon-theme' 'dconf' 'python' 'libhandy' 'gtk3' 'python-gobject' 'webkit2gtk')
+optdepends=('wine')
+makedepends=('meson' 'ninja')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mirkobrombin/Amusiz/archive/${pkgver}.tar.gz")
+sha256sums=('0fc483073ffd0a983a0ba3ceda6ecd8d9c9785f8ce254125be78dd48babcc07b')
+
+build() {
+ cd "Amusiz-${pkgver}"
+ meson --prefix='/usr' build
+ ninja -C build
+}
+
+package() {
+ cd "Amusiz-${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C build install
+}