summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorImmae2014-11-13 00:25:29 +0100
committerImmae2014-11-13 00:27:17 +0100
commit6b0e289aed80d905732536e3e58e2a99e84383c8 (patch)
tree8649c66941088e3d5011e06ddd8df9109d1ccdaa /PKGBUILD
downloadaur-6b0e289aed80d905732536e3e58e2a99e84383c8.tar.gz
Anaconda
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85e983708445
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer : Immae <ismael.bouya@normalesup.org>
+# Contributor : Martin Wimpress <code@flexion.org>
+
+pkgname=anaconda
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Completely free enterprise-ready Python distribution for large-scale data processing, predictive analytics, and scientific computing."
+arch=('x86' 'x86_64')
+url="https://store.continuum.io/cshop/anaconda/"
+license=("custom")
+makedepends=('patch')
+source=("http://repo.continuum.io/anaconda3/Anaconda3-${pkgver}-Linux-x86_64.sh"
+ "installer_sh_x86.patch"
+ "installer_sh_x86_64.patch"
+ "conda_install.patch")
+options=(!strip)
+sha256sums=('af3225ccbe8df0ffb918939e009aa57740e35058ebf9dfcf5fec794a77556c3c'
+ '5f7bcde6f9580212bf6dd86d8b62c61bbada68a3e1ef9989169ba8a43de092c1'
+ 'aacb20eb47b85430c9ec30ee09ada2f148cb43166be39b6998ae864e7fd17127'
+ '2ca6eeef44065f3ea0b4761bf2f40557af9db70eedae890e436be4a28f713c5c')
+_pythonver='3.4.1-4'
+_condaver='3.7.0'
+
+_pkgarch=`uname -m`
+if [ "$CARCH" == "i686" ]; then
+ _pkgarch="x86"
+ sha256sums[0]='657cb599004c21e37ce693515ea33922e0084fd7c159ef1b96b57c86eed8385f'
+ source[0]="http://repo.continuum.io/anaconda3/Anaconda3-${pkgver}-Linux-x86.sh"
+fi
+
+prepare() {
+ cd ${srcdir}
+ patch --follow-symlinks -p1 < installer_sh_${_pkgarch}.patch
+}
+
+package() {
+ prefix=${pkgdir}/opt/${pkgname}
+ bash ${srcdir}/Anaconda3-${pkgver}-Linux-${_pkgarch}.sh -b -p $prefix
+ cd $prefix
+ patch -p1 < $srcdir/conda_install.patch
+ CONDA_INSTALL="$prefix/pkgs/conda-${_condaver}-py34_0/lib/python3.4/site-packages/conda/install.py"
+ $prefix/pkgs/python-${_pythonver}/bin/python -E $CONDA_INSTALL --prefix=$prefix --instdir=/opt/${pkgname} --pkgs-dir=$prefix/pkgs --link-all || exit 1
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}