summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Reggiani Manzo2015-11-01 00:11:42 -0200
committerRafael Reggiani Manzo2015-11-01 00:11:42 -0200
commitcda407fa0738f228827e776b5fce5dea3a411a49 (patch)
treeb1ae8551ea56b04a25644e3e7c02b9bce8a76faa /PKGBUILD
parent8b3a392cb49033268312a043d0ed5ba7757d681e (diff)
downloadaur-cda407fa0738f228827e776b5fce5dea3a411a49.tar.gz
Add pending perl packages
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 518d62079a28..5ae9d0a993bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
pkgname=analizo
pkgver=1.18.1
-pkgrel=5
+pkgrel=6
pkgdesc="Analizo is a free, multi-language, extensible source code analysis and visualization toolkit."
groups=('analizo')
arch=('any')
url="http://analizo.org"
license=('GPLv3')
-depends=('perl' 'perl-cpanplus-dist-arch' 'sloccount' 'doxyparse'
- 'perl-chi' 'perl-test-without-module' # perl-test-without-module is only necessary as long as this issue does not gets fixed: https://github.com/rmarquis/pacaur/issues/367
- 'perl-app-cmd' 'perl-class' 'perl-data-uuid' 'perl-digest-jhash'
- 'perl-list-moreutils' 'perl-file-homedir'
+depends=('perl' 'sloccount' 'doxyparse'
+ 'perl-chi' 'perl-app-cmd' 'perl-class' 'perl-data-uuid'
+ 'perl-digest-jhash' 'perl-list-moreutils' 'perl-file-homedir'
'perl-file-copy-recursive' 'perl-getopt-euclid' 'perl-graph'
'perl-list-compare' 'perl-mro-compat' 'perl-file-sharedir-install'
'perl-params-util' 'perl-params-validate' 'perl-test-class'
- 'perl-test-exception' 'perl-yaml')
+ 'perl-test-exception' 'perl-yaml' 'perl-statistics-descriptive'
+ 'perl-statistics-online' 'perl-findbin-libs' 'perl-graph-writer-dsm')
makedepends=('git')
source=("${url}/download/${pkgname}_${pkgver}.tar.xz")
sha512sums=('2184796a58a0d8ffe52c8dcb551c620986194926437ea99ab18cad6a014346b766bec26f6848579051686ac1562c50ab19d5d164afe6c4ec78ebe958d0ee4a9c')
@@ -23,12 +23,6 @@ sha512sums=('2184796a58a0d8ffe52c8dcb551c620986194926437ea99ab18cad6a014346b766b
build(){
cd "${srcdir}/${pkgname}"
- #Perl modules
- cpanp -i --skiptest Statistics::Descriptive # Left behind on AUR 3 to 4 migration
- cpanp -i --skiptest Statistics::OnLine # Looks like there is no Oficial or AUR candidate
- cpanp -i --skiptest FindBin::libs # Looks like there is no Oficial or AUR candidate
- cpanp -i --skiptest Graph::Writer::DSM # Looks like there is no Oficial or AUR candidate
-
#Analizo
perl Makefile.PL
make