summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Reggiani Manzo2015-09-30 18:05:49 -0300
committerRafael Reggiani Manzo2015-09-30 18:05:49 -0300
commitd2aa02980c5950f64cd02616e35d767bf76fd7c5 (patch)
treec414c48576d09c7df3f189b1103fabb7e113f714 /PKGBUILD
parentc9769cf26ca5a6b5e29f57b614bab5bcdaa6349e (diff)
downloadaur-d2aa02980c5950f64cd02616e35d767bf76fd7c5.tar.gz
Make perl dependencies intalled through packages
There are four dependencies that are still unpackaged.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 12 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6ddc5e68845..e15dbccf776a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,19 @@
pkgname=analizo
pkgver=1.18.1
-pkgrel=1
+pkgrel=2
pkgdesc="Analizo is a free, multi-language, extensible source code analysis and visualization toolkit."
groups=('analizo')
arch=('any')
url="http://analizo.org"
license=('GPLv3')
-depends=('perl' 'perl-cpanplus-dist-arch' 'sloccount' 'doxyparse')
+depends=('perl' 'perl-cpanplus-dist-arch' 'sloccount' 'doxyparse'
+ 'perl-app-cmd' 'perl-chi' 'perl-class' 'perl-data-uuid'
+ 'perl-digest-jhash' 'perl-list-moreutils' 'perl-file-homedir'
+ 'perl-file-copy-recursive' 'perl-getopt-euclid' 'perl-graph'
+ 'perl-list-compare' 'perl-mro-compat' 'perl-file-sharedir-install'
+ 'perl-params-util' 'perl-params-validate' 'perl-test-class'
+ 'perl-test-exception' 'perl-yaml')
makedepends=('git')
source=("${url}/download/${pkgname}_${pkgver}.tar.xz")
sha512sums=('2184796a58a0d8ffe52c8dcb551c620986194926437ea99ab18cad6a014346b766bec26f6848579051686ac1562c50ab19d5d164afe6c4ec78ebe958d0ee4a9c')
@@ -17,29 +23,10 @@ build(){
cd "${srcdir}/${pkgname}"
#Perl modules
- cpanp -i --skiptest Class::Accessor
- cpanp -i --skiptest Getopt::Euclid
- cpanp -i --skiptest Graph
- cpanp -i --skiptest List::Compare
- cpanp -i --skiptest Statistics::Descriptive
- cpanp -i --skiptest Statistics::OnLine
- cpanp -i --skiptest MRO::Compat
- cpanp -i --skiptest Test::Class
- cpanp -i --skiptest Test::Exception
- cpanp -i --skiptest YAML
- cpanp -i --skiptest File::ShareDir::Install
- cpanp -i --skiptest FindBin::libs
- cpanp -i --skiptest App::Cmd::Setup
- cpanp -i --skiptest Class::Inspector
- cpanp -i --skiptest Graph::Writer::DSM
- cpanp -i --skiptest File::HomeDir
- cpanp -i --skiptest CHI
- cpanp -i --skiptest File::Copy::Recursive
- cpanp -i --skiptest Params::Util
- cpanp -i --skiptest List::MoreUtils
- cpanp -i --skiptest Data::UUID
- cpanp -i --skiptest Params::Validate
- cpanp -i --skiptest Digest::JHash
+ cpanp -i --skiptest Statistics::Descriptive # Looks like there is no Oficial or AUR candidate
+ cpanp -i --skiptest Statistics::OnLine # Looks like there is no Oficial or AUR candidate
+ cpanp -i --skiptest FindBin::libs # Looks like there is no Oficial or AUR candidate
+ cpanp -i --skiptest Graph::Writer::DSM # Looks like there is no Oficial or AUR candidate
#Analizo
perl Makefile.PL