summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntoine Viallon2021-05-08 22:27:26 +0200
committerAntoine Viallon2021-05-08 22:27:26 +0200
commit14c90168ff6aaf43e213497f4a76dfafdbb24cef (patch)
tree4ac4b5ec54437aad9ba54a1feb56c84ea33915e2 /PKGBUILD
parentc3f2942b259529623f4dbd0e8e0ab1387d901a7e (diff)
downloadaur-14c90168ff6aaf43e213497f4a76dfafdbb24cef.tar.gz
Update to version 0.3.1, added systemd dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f130dd859832..cd89eeafcc62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
pkgname=ananicy-cpp
-pkgver=0.2.1
+pkgver=0.3.1
pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
+url="https://gitlab.com/aviallon/ananicy-cpp/"
+license=(GPLv3)
source=(
- "git+https://gitlab.com/aviallon/ananicy-cpp.git#tag=v${pkgver}"
+ "https://gitlab.com/aviallon/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz"
)
-md5sums=(SKIP)
+md5sums=('55da67ba131d138242f10c708a69bcd6')
arch=(x86_64 i386 armv7h)
-depends=(ananicy fmt spdlog nlohmann-json)
+depends=(ananicy fmt spdlog nlohmann-json systemd)
makedepends=(cmake git)
prepare() {
- cd "$pkgname"
+ cd "$pkgname-v${pkgver}"
mkdir -p build
cd build
@@ -20,17 +22,18 @@ prepare() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_EXTERNAL_SPDLOG=ON \
-DUSE_EXTERNAL_JSON=ON \
- -DUSE_EXTERNAL_FMTLIB=ON
+ -DUSE_EXTERNAL_FMTLIB=ON \
+ -DVERSION=${pkgver}
}
build() {
- cd "$pkgname/build"
+ cd "$pkgname-v${pkgver}/build"
cmake --build .
}
package() {
- cd "$pkgname/build"
+ cd "$pkgname-v${pkgver}/build"
export DESTDIR="$pkgdir"
cmake --install .