summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntoine Viallon2021-04-22 01:07:32 +0200
committerAntoine Viallon2021-04-22 01:07:32 +0200
commit2f551f1e77b3b922303088058a1efc664111317a (patch)
treeaf79fde60e8f57827f8d930b6ec5c066ee048e03 /PKGBUILD
downloadaur-2f551f1e77b3b922303088058a1efc664111317a.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc12643157ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=ananicy-cpp
+pkgver=0.1.1.1
+pkgrel=1
+pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
+source=(
+ "git+https://gitlab.com/aviallon/ananicy-cpp.git#tag=v${pkgver}"
+ )
+md5sums=(SKIP)
+arch=(x86_64 i386 armv7h)
+depends=(ananicy fmt spdlog nlohmann-json)
+
+prepare() {
+ cd "$pkgname"
+
+ mkdir -p build
+ cd build
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_EXTERNAL_SPDLOG=ON \
+ -DUSE_EXTERNAL_JSON=ON
+}
+
+build() {
+ cd "$pkgname/build"
+
+ cmake --build .
+}
+
+package() {
+ cd "$pkgname/build"
+
+ export DESTDIR="$pkgdir"
+ cmake --install .
+}
+