summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntoine Viallon2022-01-12 23:11:57 +0100
committerAntoine Viallon2022-01-12 23:11:57 +0100
commit44677c949bca9c25b4c16bde0a7adcd6b3f3f4d5 (patch)
treec3e44942e9677fc37be38b6059cdea9bb09c9055 /PKGBUILD
parentfa1e620f7f1badeab1521c5882a6434df683045e (diff)
downloadaur-44677c949bca9c25b4c16bde0a7adcd6b3f3f4d5.tar.gz
Cleanup build and fix install function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a88f7f27390e..65782717ab69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ananicy-cpp
_pkgver=1.0.0-rc5
pkgver=${_pkgver//-/.}
-pkgrel=1
+pkgrel=2
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
url="https://gitlab.com/ananicy-cpp/ananicy-cpp/"
license=(GPLv3)
@@ -31,16 +31,16 @@ prepare() {
}
build() {
- cd "$pkgname-v${_pkgver}/build"
+ cd "$pkgname-v${_pkgver}"
- cmake --build .
+ cmake --build build
}
package() {
- cd "$pkgname-v${_pkgver}/build"
+ cd "$pkgname-v${_pkgver}"
export DESTDIR="$pkgdir"
- cmake --install .
+ cmake --install build --component Runtime
install -m755 -d "$pkgdir/etc/ananicy.d"
}