summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntoine Viallon2021-05-27 18:18:37 +0200
committerAntoine Viallon2021-05-27 18:18:37 +0200
commit887758c3e0f8ff4baff78d43480ffeb1aa335b45 (patch)
tree80179dddf5d15431744adfdb9563fe120a2f74b2 /PKGBUILD
parent54e536b818091852865025d6cea004b6063a1aeb (diff)
downloadaur-887758c3e0f8ff4baff78d43480ffeb1aa335b45.tar.gz
Add /etc/ananicy.d folder in package() to avoid crashes. Also added why ananicy is an optional dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1792ef329aa8..8f7e1c665c04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=ananicy-cpp
pkgver=0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
url="https://gitlab.com/aviallon/ananicy-cpp/"
license=(GPLv3)
@@ -11,7 +11,7 @@ md5sums=('a1a3a551f8e0ce8a3b70bcd32804ec70')
arch=(x86_64 i386 armv7h)
depends=(fmt spdlog nlohmann-json systemd)
makedepends=(cmake git)
-optdepends=(ananicy)
+optdepends=("ananicy: community rules")
prepare() {
cd "$pkgname-v${pkgver}"
@@ -38,5 +38,7 @@ package() {
export DESTDIR="$pkgdir"
cmake --install .
+
+ install -m755 -d "$pkgdir/etc/ananicy.d"
}