summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntoine Viallon2021-07-31 01:21:13 +0200
committerAntoine Viallon2021-07-31 01:21:13 +0200
commitfa52f0128c041945cb0ded086fa2b9889fa99f4a (patch)
tree6020ec6aa8033afd19caf31c8d52648365535076 /PKGBUILD
parente150864eb2b2b973c1b984eadc53acd471dc3ee3 (diff)
downloadaur-fa52f0128c041945cb0ded086fa2b9889fa99f4a.tar.gz
Update to 1.0.0-rc1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 94b1141b1121..2f8e04940be5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: Antoine Viallon <antoine@lesviallon.fr>
pkgname=ananicy-cpp
-pkgver=0.8.1
+_pkgver=1.0.0-rc1
+pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
url="https://gitlab.com/ananicy-cpp/ananicy-cpp/"
license=(GPLv3)
source=(
- "https://gitlab.com/ananicy-cpp/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz"
+ "https://gitlab.com/ananicy-cpp/${pkgname}/-/archive/v${_pkgver}/${pkgname}-v${_pkgver}.tar.gz"
)
-md5sums=('9dc6733e150b4abd57ae79be8789c729')
+md5sums=('8f5de902bbe00434a0ce7bdd00c82a94')
arch=(x86_64 i386 armv7h)
depends=(fmt spdlog nlohmann-json systemd)
makedepends=(cmake git)
optdepends=("ananicy-rules-git: community rules")
prepare() {
- cd "$pkgname-v${pkgver}"
+ cd "$pkgname-v${_pkgver}"
mkdir -p build
cd build
@@ -26,17 +27,17 @@ prepare() {
-DUSE_EXTERNAL_SPDLOG=ON \
-DUSE_EXTERNAL_JSON=ON \
-DUSE_EXTERNAL_FMTLIB=ON \
- -DVERSION=${pkgver}
+ -DVERSION=${_pkgver}
}
build() {
- cd "$pkgname-v${pkgver}/build"
+ cd "$pkgname-v${_pkgver}/build"
cmake --build .
}
package() {
- cd "$pkgname-v${pkgver}/build"
+ cd "$pkgname-v${_pkgver}/build"
export DESTDIR="$pkgdir"
cmake --install .