summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTimofey Titovets2016-04-30 05:00:14 +0300
committerTimofey Titovets2016-04-30 05:00:14 +0300
commitf630ccc5da795c3452d9a8e19227233d6f744fed (patch)
treea256c06a0f656f2314a25946298a70d39c436806 /PKGBUILD
downloadaur-f630ccc5da795c3452d9a8e19227233d6f744fed.tar.gz
Created
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45e6a9f9a6b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Timofey Titovets <nefelim4ag@gmail.com>
+
+pkgname=ananicy-git
+pkgver=0.0000001
+pkgrel=1
+pkgdesc="Ananicy - is Another auto nice daemon, with community rules support"
+arch=('x86_64' 'i686')
+url="https://github.com/Nefelim4ag/Ananicy.git"
+license=('GPL3')
+depends=('systemd' 'bash')
+source=("$pkgname"::'git://github.com/Nefelim4ag/Ananicy.git#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ mkdir -p "$pkgdir"/etc/
+ mv "$srcdir"/$pkgname/ananicy.d "$pkgdir"/etc/
+ install -Dm644 "$srcdir"/$pkgname/ananicy.service "$pkgdir"/usr/lib/systemd/system/ananicy.service
+ install -Dm755 "$srcdir"/$pkgname/ananicy.sh "$pkgdir"/usr/lib/systemd/scripts/ananicy.sh
+}